Mikrotik Throttling

Posted in How Did I Do That?

The most simple method of throttling is PCQ. A simple method for this is:

/queue type
add kind=pcq name="192.168.88.0/24 Download" pcq-dst-address6-mask=64 \
pcq-limit=300KiB pcq-rate=8M pcq-src-address6-mask=64 pcq-total-limit=\
35000000KiB
add kind=pcq name="192.168.88.0/24 Upload" pcq-dst-address6-mask=64 pcq-limit=\
300KiB pcq-rate=3M pcq-src-address6-mask=64 pcq-total-limit=12000000KiB
/queue tree
add comment="192.168.88.0/24 Download" name="192.168.88.0/24 Download" \
packet-mark="192.168.88.0/24 Download" parent=global queue=\
"192.168.88.0/24 Download"
add comment="192.168.88.0/24 Upload" name="192.168.88.0/24 Upload" packet-mark=\
"192.168.88.0/24 Upload" parent=global queue="192.168.88.0/24 Upload"
/ip firewall mangle
add action=mark-packet chain=forward comment="192.168.88.0/24 Download" \
dst-address=192.168.88.0/24 in-interface=ether1-WAN new-packet-mark=\
"192.168.88.0/24 Download"
add action=mark-packet chain=forward comment="192.168.88.0/24 Upload" \
new-packet-mark="192.168.88.0/24 Upload" src-address=192.168.88.0/24